解决React-native init 初始化时 info Installing required CocoaPods dependencies

最近做React Native的时候,React-native init 初始化时出现一个问题,

info Installing required CocoaPods dependencies

在网上找了下原因,主要是网络慢或网络连接的原因,解决方案如下

一、Ctrl + c 退出命令行

二、安装Cocoapods

sudo gem install cocoapods

三、设置镜像

$ cd ~/.cocoapods/repos 
$ pod repo remove master
$ git clone https://mirrors.tuna.tsinghua.edu.cn/git/CocoaPods/Specs.git master

四、进入自己的工程, 在自己工程的podFile第一行加上:

source 'https://mirrors.tuna.tsinghua.edu.cn/git/CocoaPods/Specs.git'

五、安装

pod install

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注